Prihlásiť sa Odoslať Novinky :: FAQ :: Rozšírené vyhľadávanie :: Napísali o nás :: Ankety
Main Menu
· Home
· 
· FAQ
· 
· Diskusia
· 











Main Menu
· Domov

Moduly
· AvantGo
· Downloads
· FAQ
· News
· Recommend Us
· Reviews
· Search
· Sections
· Stats
· Topics
· Top List
· Web Links
· Forum

Jazyk
Výber jazykovej mutácie:



The time now is 22.11.2017 - 17:34


skript na kontrolu celeho mikrotiku

Post new topic Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
 
Author Message
pedro4444
Post subject: skript na kontrolu celeho mikrotiku  PostPosted: 30.11.2015 - 10:38 #110069
Ucen


Joined: Júl 15, 2011
Posts: 722

Zdravím
Aj vdaka vasim radam a nasmerovaniu som teda dobojoval skript na komplet kontrolu mikrotiku.
Spusti si ho sam scheduler raz za den a skontroluje mi podla toho co dany mk robi. (sam si zapnem co vsetko ma v tom skripte kontrolovat)
1) Ethernety ci su ako maju byt, error ci nemaju nejake
2) cpu ci nie je seknute
3) velkost volneho miesta, pretoze sa mi obcas stalo, ze sa mi aj to zahadzalo....
4) Signaly ci nie su pod hodnotu, ktoru si zvolim.

Ak nieco prekroci dany limit pride mi email opakujem je to amatersky spravene za pomoci vasich rad, takze kludne ak niekoho nieco napadne co by sa tam dalo este dorobit alebo doladit (zjednodusit) si necham poradit. Preto to tu aj zverejnujem bez problemov aj ked som s tym zabil hodiny práce, ale v zivote sa treba drzat pomozu tebe podel sa aj ty.
Za vase dotazy vopred diki

Code: ›
#ci ma kontrolovat signal klientov (1 ano   0 nie) a nastavit uroven pod ktoru ked klesne nech to pride
:local wirelesskontroluje "0";
:local hranicnahodnotasignalov "-70";

# NASTAVENIE ETHERNETOV ci su alebo nie- (1 ano   0 nie) a treba nastavit aku by mal mat rychlost (100Mbps alebo 1Gbps)
:local etherport1 "0"
:local rychlostetherport1 "1Gbps"
:local etherport2 "0"
:local rychlostetherport2 "100Mbps"
:local etherport3 "0"
:local rychlostetherport3 "1Gbps"
:local etherport4 "0"
:local rychlostetherport4 "100Mbps"
:local etherport5 "0"
:local rychlostetherport5 "100Mbps"
:local etherport6 "0"
:local rychlostetherport6 "100Mbps"
:local etherport7 "0"
:local rychlostetherport7 "1Gbps"
:local etherport8 "0"
:local rychlostetherport8 "100Mbps"
:local etherport9 "0"
:local rychlostetherport9 "100Mbps"
:local etherport10 "0"
:local rychlostetherport10 "100Mbps"
:local etherport11 "0"
:local rychlostetherport11 "100Mbps"
:local etherport12 "0"
:local rychlostetherport12 "100Mbps"
:local etherport13 "0"
:local rychlostetherport13 "100Mbps"
:local etherport14 "0"
:local rychlostetherport14 "100Mbps"
:local etherport15 "0"
:local rychlostetherport15 "100Mbps"

# error ethernet treba nastavit hranicnu hodnotu errorov
:local hranicnahodnotaetherneterror "0"
:local spravaprezlyethernet "klesol pod"

# HDD volne miesto treba nastavit hranicnu hodnotu v MB (len cislo)
:local hranicnahodnotavolnemiestonadisku "5"
:local spravapredmetuvolnemiestonadisku "volne miesto v MK HDD kleslo pod"

# CPU treba nastavit hranicnu hodnotu
:local hranicnahodnotacpu "90"
:local spravapredmetucpu "procesor ide nad"


:local vysledokcelkovo "0"
:local thisbox [/system identity get name]
:local thistime [/system clock get time]


#cast skriptu pre testovanie cpu
:local vytazeniecpu1 [/system resource get cpu-load]
 :delay 100s
:local vytazeniecpu2 [/system resource get cpu-load]
:local vysledokcpu "0"
:local predmetcpu

:if ($vytazeniecpu1 > $hranicnahodnotacpu) do={
 :delay 1s
:if ($vytazeniecpu2 > $hranicnahodnotacpu) do={
:set vysledokcpu 1;
}
}
 :delay 1s
 if ($vysledokcpu= 1) do={
:set vysledokcelkovo "1"
:set predmetcpu "$spravapredmetucpu $hranicnahodnotacpu%"
}

:delay 1s

#cast skriptu pre testovanie volneho miesta
:local volnemiestonadisku1 (([/system resource get free-hdd-space]/1024)/1024)
:local volnemiestonadisku2 (([/system resource get free-hdd-space]/1024)/1024)
:local vysledokvolnemiestonadisku "0"
:local predmetvolnemiestonadisku

:if ($volnemiestonadisku1 < $hranicnahodnotavolnemiestonadisku) do={
 :delay 100s
:if ($volnemiestonadisku2 < $hranicnahodnotavolnemiestonadisku) do={
:set vysledokvolnemiestonadisku 1;
}
}
:delay 1s
 if ($vysledokvolnemiestonadisku= 1) do={
:set vysledokcelkovo "1"
:set predmetvolnemiestonadisku "$spravapredmetuvolnemiestonadisku $hranicnahodnotavolnemiestonadisku MB"
}


#cast skriptu pre testovanie ethernetov
:local predmetetherportrychlost1;
:local predmetetherportrychlost2;
:local predmetetherportrychlost3;
:local predmetetherportrychlost4;
:local predmetetherportrychlost5;
:local predmetetherportrychlost6;
:local predmetetherportrychlost7;
:local predmetetherportrychlost8;
:local predmetetherportrychlost9;
:local predmetetherportrychlost10;
:local predmetetherportrychlost11;
:local predmetetherportrychlost12;
:local predmetetherportrychlost13;
:local predmetetherportrychlost14;
:local predmetetherportrychlost15;
:local predmeterrorfcsetherport1;
:local predmeterrorfcsetherport2;
:local predmeterrorfcsetherport3;
:local predmeterrorfcsetherport4;
:local predmeterrorfcsetherport5;
:local predmeterrorfcsetherport6;
:local predmeterrorfcsetherport7;
:local predmeterrorfcsetherport8;
:local predmeterrorfcsetherport9;
:local predmeterrorfcsetherport10;
:local predmeterrorfcsetherport11;
:local predmeterrorfcsetherport12;
:local predmeterrorfcsetherport13;
:local predmeterrorfcsetherport14;
:local predmeterrorfcsetherport15;
:local predmeterroralignetherport1;
:local predmeterroralignetherport2;
:local predmeterroralignetherport3;
:local predmeterroralignetherport4;
:local predmeterroralignetherport5;
:local predmeterroralignetherport6;
:local predmeterroralignetherport7;
:local predmeterroralignetherport8;
:local predmeterroralignetherport9;
:local predmeterroralignetherport10;
:local predmeterroralignetherport11;
:local predmeterroralignetherport12;
:local predmeterroralignetherport13;
:local predmeterroralignetherport14;
:local predmeterroralignetherport15;
:local vysledokerrorether1 "0"
:local vysledokerrorether2 "0"
:local vysledokerrorether3 "0"
:local vysledokerrorether4 "0"
:local vysledokerrorether5 "0"
:local vysledokerrorether6 "0"
:local vysledokerrorether7 "0"
:local vysledokerrorether8 "0"
:local vysledokerrorether9 "0"
:local vysledokerrorether10 "0"
:local vysledokerrorether11 "0"
:local vysledokerrorether12 "0"
:local vysledokerrorether13 "0"
:local vysledokerrorether14 "0"
:local vysledokerrorether15 "0"
:local predmetcelkovykontrolaethernetov;


if ($etherport1= 1) do={
/interface ethernet monitor ether1 once do={:if ($"rate" = "$rychlostetherport1") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost1 "eth1 $spravaprezlyethernet $rychlostetherport1"
}
}
:local ether1fcserror [/interface ethernet get ether1 rx-fcs-error]
:local ether1alignerror [/ interface ethernet get ether1 rx-align-error]
:if ($ether1fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether1 1
:set predmeterrorfcsetherport1 "eth1 fcs-error= $ether1fcserror"
}
:delay 1
:if ($ether1alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether1 1
:set predmeterroralignetherport1 "eth1 align-error= $ether1alignerror"
}
:if ($vysledokerrorether1 > 0) do={
interface ethernet reset-counters ether1
}
}
 :delay 1s
if ($etherport2= 1) do={
/interface ethernet monitor ether2 once do={:if ($"rate" = "$rychlostetherport2") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost2 "eth2 $spravaprezlyethernet $rychlostetherport2"
}
}
:local ether2fcserror [/interface ethernet get ether2 rx-fcs-error]
:local ether2alignerror [/ interface ethernet get ether2 rx-align-error]
:if ($ether2fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether2 1
:set predmeterrorfcsetherport2 "eth2 fcs-error= $ether2fcserror"
}
:delay 1
:if ($ether2alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether2 1
:set predmeterroralignetherport2 "eth2 align-error= $ether2alignerror"
}
:if ($vysledokerrorether2 > 0) do={
interface ethernet reset-counters ether2
}
}
 :delay 1s
if ($etherport3= 1) do={
/interface ethernet monitor ether3 once do={:if ($"rate" = "$rychlostetherport3") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost3 "eth3 $spravaprezlyethernet $rychlostetherport3"
}
}
:local ether3fcserror [/interface ethernet get ether3 rx-fcs-error]
:local ether3alignerror [/ interface ethernet get ether3 rx-align-error]
:if ($ether3fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether3 1
:set predmeterrorfcsetherport3 "eth3 fcs-error= $ether3fcserror"
}
:delay 1
:if ($ether3alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether3 1
:set predmeterroralignetherport3 "eth3 align-error= $ether3alignerror"
}
:if ($vysledokerrorether3 > 0) do={
interface ethernet reset-counters ether3
}
}
 :delay 1s
if ($etherport4= 1) do={
/interface ethernet monitor ether4 once do={:if ($"rate" = "$rychlostetherport4") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost4 "eth4 $spravaprezlyethernet $rychlostetherport4"
}
}
:local ether4fcserror [/interface ethernet get ether4 rx-fcs-error]
:local ether4alignerror [/ interface ethernet get ether4 rx-align-error]
:if ($ether4fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether4 1
:set predmeterrorfcsetherport4 "eth4 fcs-error= $ether4fcserror"
}
:delay 1
:if ($ether4alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether4 1
:set predmeterroralignetherport4 "eth4 align-error= $ether4alignerror"
}
:if ($vysledokerrorether4 > 0) do={
interface ethernet reset-counters ether4
}
}
 :delay 1s
if ($etherport5= 1) do={
/interface ethernet monitor ether5 once do={:if ($"rate" = "$rychlostetherport5") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost5 "eth5 $spravaprezlyethernet $rychlostetherport5"
}
}
:local ether5fcserror [/interface ethernet get ether5 rx-fcs-error]
:local ether5alignerror [/ interface ethernet get ether5 rx-align-error]
:if ($ether5fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether5 1
:set predmeterrorfcsetherport5 "eth5 fcs-error= $ether5fcserror"
}
:delay 1
:if ($ether5alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether5 1
:set predmeterroralignetherport5 "eth5 align-error= $ether5alignerror"
}
:if ($vysledokerrorether5 > 0) do={
interface ethernet reset-counters ether5
}
}
 :delay 1s
if ($etherport6= 1) do={
/interface ethernet monitor ether6 once do={:if ($"rate" = "$rychlostetherport6") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost6 "eth6 $spravaprezlyethernet $rychlostetherport6"
}
}
:local ether6fcserror [/interface ethernet get ether6 rx-fcs-error]
:local ether6alignerror [/ interface ethernet get ether6 rx-align-error]
:if ($ether6fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether6 1
:set predmeterrorfcsetherport6 "eth6 fcs-error= $ether6fcserror"
}
:delay 1
:if ($ether6alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether6 1
:set predmeterroralignetherport6 "eth6 align-error= $ether6alignerror"
}
:if ($vysledokerrorether6 > 0) do={
interface ethernet reset-counters ether6
}
}
 :delay 1s
if ($etherport7= 1) do={
/interface ethernet monitor ether7 once do={:if ($"rate" = "$rychlostetherport7") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost7 "eth7 $spravaprezlyethernet $rychlostetherport7"
}
}
:local ether7fcserror [/interface ethernet get ether7 rx-fcs-error]
:local ether7alignerror [/ interface ethernet get ether7 rx-align-error]
:if ($ether7fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether7 1
:set predmeterrorfcsetherport7 "eth7 fcs-error= $ether7fcserror"
}
:delay 1
:if ($ether7alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether7 1
:set predmeterroralignetherport7 "eth7 align-error= $ether7alignerror"
}
:if ($vysledokerrorether7 > 0) do={
interface ethernet reset-counters ether7
}
}
 :delay 1s
if ($etherport8= 1) do={
/interface ethernet monitor ether8 once do={:if ($"rate" = "$rychlostetherport8") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost8 "eth8 $spravaprezlyethernet $rychlostetherport8"
}
}
:local ether8fcserror [/interface ethernet get ether8 rx-fcs-error]
:local ether8alignerror [/ interface ethernet get ether8 rx-align-error]
:if ($ether8fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether8 1
:set predmeterrorfcsetherport8 "eth8 fcs-error= $ether8fcserror"
}
:delay 1
:if ($ether8alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether8 1
:set predmeterroralignetherport8 "eth8 align-error= $ether8alignerror"
}
:if ($vysledokerrorether8 > 0) do={
interface ethernet reset-counters ether8
}
}
 :delay 1s
if ($etherport9= 1) do={
/interface ethernet monitor ether9 once do={:if ($"rate" = "$rychlostetherport9") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost9 "eth9 $spravaprezlyethernet $rychlostetherport9"
}
}
:local ether9fcserror [/interface ethernet get ether9 rx-fcs-error]
:local ether9alignerror [/ interface ethernet get ether9 rx-align-error]
:if ($ether9fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether9 1
:set predmeterrorfcsetherport9 "eth9 fcs-error= $ether9fcserror"
}
:delay 1
:if ($ether9alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether9 1
:set predmeterroralignetherport9 "eth9 align-error= $ether9alignerror"
}
:if ($vysledokerrorether9 > 0) do={
interface ethernet reset-counters ether9
}
}
 :delay 1s
if ($etherport10= 1) do={
/interface ethernet monitor ether10 once do={:if ($"rate" = "$rychlostetherport10") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost10 "eth10 $spravaprezlyethernet $rychlostetherport10"
}
}
:local ether10fcserror [/interface ethernet get ether10 rx-fcs-error]
:local ether10alignerror [/ interface ethernet get ether10 rx-align-error]
:if ($ether10fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether10 1
:set predmeterrorfcsetherport10 "eth10 fcs-error= $ether10fcserror"
}
:delay 1
:if ($ether10alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether10 1
:set predmeterroralignetherport10 "eth10 align-error= $ether10alignerror"
}
:if ($vysledokerrorether10 > 0) do={
interface ethernet reset-counters ether10
}
}
 :delay 1s
if ($etherport11= 1) do={
/interface ethernet monitor ether11 once do={:if ($"rate" = "$rychlostetherport11") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost11 "eth11 $spravaprezlyethernet $rychlostetherport11"
}
}
:local ether11fcserror [/interface ethernet get ether11 rx-fcs-error]
:local ether11alignerror [/ interface ethernet get ether11 rx-align-error]
:if ($ether11fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether11 1
:set predmeterrorfcsetherport11 "eth11 fcs-error= $ether11fcserror"
}
:delay 1
:if ($ether11alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether11 1
:set predmeterroralignetherport11 "eth11 align-error= $ether11alignerror"
}
:if ($vysledokerrorether11 > 0) do={
interface ethernet reset-counters ether11
}
}
 :delay 1s
if ($etherport12= 1) do={
/interface ethernet monitor ether12 once do={:if ($"rate" = "$rychlostetherport12") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost12 "eth12 $spravaprezlyethernet $rychlostetherport12"
}
}
:local ether12fcserror [/interface ethernet get ether12 rx-fcs-error]
:local ether12alignerror [/ interface ethernet get ether12 rx-align-error]
:if ($ether12fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether12 1
:set predmeterrorfcsetherport12 "eth12 fcs-error= $ether12fcserror"
}
:delay 1
:if ($ether12alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether12 1
:set predmeterroralignetherport12 "eth12 align-error= $ether12alignerror"
}
:if ($vysledokerrorether12 > 0) do={
interface ethernet reset-counters ether12
}
}
 :delay 1s
if ($etherport13= 1) do={
/interface ethernet monitor ether13 once do={:if ($"rate" = "$rychlostetherport13") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost13 "eth13 $spravaprezlyethernet $rychlostetherport13"
}
}
:local ether13fcserror [/interface ethernet get ether13 rx-fcs-error]
:local ether13alignerror [/ interface ethernet get ether13 rx-align-error]
:if ($ether13fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether13 1
:set predmeterrorfcsetherport13 "eth13 fcs-error= $ether13fcserror"
}
:delay 1
:if ($ether13alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether13 1
:set predmeterroralignetherport13 "eth13 align-error= $ether13alignerror"
}
:if ($vysledokerrorether13 > 0) do={
interface ethernet reset-counters ether13
}
}
 :delay 1s
if ($etherport14= 1) do={
/interface ethernet monitor ether14 once do={:if ($"rate" = "$rychlostetherport14") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost14 "eth14 $spravaprezlyethernet $rychlostetherport14"
}
}
:local ether14fcserror [/interface ethernet get ether14 rx-fcs-error]
:local ether14alignerror [/ interface ethernet get ether14 rx-align-error]
:if ($ether14fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether14 1
:set predmeterrorfcsetherport14 "eth14 fcs-error= $ether14fcserror"
}
:delay 1
:if ($ether14alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether14 1
:set predmeterroralignetherport14 "eth14 align-error= $ether14alignerror"
}
:if ($vysledokerrorether14 > 0) do={
interface ethernet reset-counters ether14
}
}
 :delay 1s
if ($etherport15= 1) do={
/interface ethernet monitor ether15 once do={:if ($"rate" = "$rychlostetherport15") do={
} else={
:set vysledokcelkovo 1
:set predmetetherportrychlost15 "eth15 $spravaprezlyethernet $rychlostetherport15"
}
}
:local ether15fcserror [/interface ethernet get ether15 rx-fcs-error]
:local ether15alignerror [/ interface ethernet get ether15 rx-align-error]
:if ($ether15fcserror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether15 1
:set predmeterrorfcsetherport15 "eth15 fcs-error= $ether15fcserror"
}
:delay 1
:if ($ether15alignerror > $hranicnahodnotaetherneterror) do={
:set vysledokcelkovo 1
:set vysledokerrorether15 1
:set predmeterroralignetherport15 "eth15 align-error= $ether15alignerror"
}
:if ($vysledokerrorether15 > 0) do={
interface ethernet reset-counters ether15
}
}

:set predmetcelkovykontrolaethernetov "$predmetetherportrychlost1 $predmeterrorfcsetherport1 $predmeterroralignetherport1 $predmetetherportrychlost2 $predmeterrorfcsetherport2 $predmeterroralignetherport2 $predmetetherportrychlost3 $predmeterrorfcsetherport3 $predmeterroralignetherport3 $predmetetherportrychlost4 $predmeterrorfcsetherport4 $predmeterroralignetherport4 $predmetetherportrychlost5 $predmeterrorfcsetherport5 $predmeterroralignetherport5 $predmetetherportrychlost6 $predmeterrorfcsetherport6 $predmeterroralignetherport6 $predmetetherportrychlost7 $predmeterrorfcsetherport7 $predmeterroralignetherport7 $predmetetherportrychlost8 $predmeterrorfcsetherport8 $predmeterroralignetherport8 $predmetetherportrychlost9 $predmeterrorfcsetherport9 $predmeterroralignetherport9 $predmetetherportrychlost10 $predmeterrorfcsetherport10 $predmeterroralignetherport10 $predmetetherportrychlost11 $predmeterrorfcsetherport11 $predmeterroralignetherport11 $predmetetherportrychlost12 $predmeterrorfcsetherport12 $predmeterroralignetherport12 $predmetetherportrychlost13 $predmeterrorfcsetherport13 $predmeterroralignetherport13 $predmetetherportrychlost14 $predmeterrorfcsetherport14 $predmeterroralignetherport14 $predmetetherportrychlost15 $predmeterrorfcsetherport15 $predmeterroralignetherport15";



:delay 1s
#cast skriptu celkove vyhodnotenie a odoslanie spravy

:if ($vysledokcelkovo = 1) do={
/tool e-mail send to="nono@gmail.com" subject="Warning kontrolny skript $vyppredmet $thisbox $thistime" body="$predmetcpu , $predmetvolnemiestonadisku , $predmetcelkovykontrolaethernetov"

:log warning "Odoslane upozornenie $predmetcpu , $predmetvolnemiestonadisku , $predmetcelkovykontrolaethernetov"
}


:delay 1s
#cast skritpu pre testovanie signalu
:local signalrx;
:local signalurovenrx;
:local signalradionamerx;
:local signallastiprx;
:local predmetsignalrx;
if ($wirelesskontroluje= 1) do={
:foreach i in=[ /int wir reg find ap=no] do={
:set signalrx [int wir reg get $i signal-strength];
:set signalrx [ :pick $signalrx 0 [:find $signalrx "dBm"]]
:if ($signalrx < $hranicnahodnotasignalov) do={
:set signalurovenrx [/interface wireless registration-table get $i signal-strength]
:set signalradionamerx [/interface wireless registration-table get $i radio-name]
:set signallastiprx [/interface wireless registration-table get $i last-ip]
:set predmetsignalrx "SignalStrength RX: $signalurovenrx $signalradionamerx $signallastiprx"
/tool e-mail send to="nono@gmail.com" subject="Warning kontrolny skript $vyppredmet $thisbox $thistime" body="$predmetsignalrx"

:log warning "Odoslane upozornenie $predmetsignalrx";
}
}
:delay 1s
:local signaltx;
:local signaluroventx;
:local signalradionametx;
:local signallastiptx;
:local predmetsignaltx;
:foreach i in=[ /int wir reg find ap=no] do={
:set signaltx [int wir reg get $i tx-signal-strength];
:if ($signaltx < $hranicnahodnotasignalov) do={
:set signaluroventx [/interface wireless registration-table get $i tx-signal-strength]
:set signalradionametx [/interface wireless registration-table get $i radio-name]
:set signallastiptx [/interface wireless registration-table get $i last-ip]
:set predmetsignaltx "SignalStrength TX: $signaluroventx $signalradionametx $signallastiptx"
/tool e-mail send to="nono@gmail.com" subject="Warning kontrolny skript $vyppredmet $thisbox $thistime" body="$predmetsignaltx"

:log warning "Odoslane upozornenie $predmetsignaltx";
}
}
}
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
pedro4444
Post subject: skript na kontrolu celeho mikrotiku  PostPosted: 01.12.2015 - 14:20 #110076
Ucen


Joined: Júl 15, 2011
Posts: 722

nikto nema k tomu ziadny dotaz alebo este napad co by sa este mohlo dorobit a mali by sme to kompletne???
alebo ste vsetci len kopcili? Very Happy
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
All times are GMT
Post new topic Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
 
Jump to:  

Powered by PNphpBB2 © 2003-2005 The PNphpBB Group
Credits

(C) SKFree 2002-2010: Powered by POSTNUKE. Môžete prebera? naše správy vo formáte XML(RSS)